Transparency and Volumetric Lighting.

Project:YafaRay
Component:YafaRay Core
Category:bug report
Priority:normal
Assigned:David Bluecame
Status:closed
Description

Hi David,

As already anticipated in a previous post, we have this problem with transparent objects when using Volumetric effects. This issue is already known and very similar to this case: http://www.yafaray.org/phpBB3/viewtopic.php?f=22&t=2951

I have attached a rendering that shows exactly what I mean. This problem isn't high priority because volumetric lighting is only active in our development truck but we would like to have our users take advantage of this feature.

Please let us know what you think.

Best regards

John

ACCA Software S.p.A.

AttachmentSize
Render_Volumetric_Yafa_0.1.99_Beta4c_01.jpg429.31 KB

Comments

#1

Hello,

After I finish with the current changes for Render Passes and other improvements, I will start working on improving the material system.

As you mention there are several reports about volumetric and transparency issues, so volumetrics/transparency is one of the aspecs I will work on.

I will keep this as "active" until we can start working on it.

#2

Okay!

Thanks David...

#3

Assigned to:Anonymous» David Bluecame
Status:active» ready to commit

This is a duplicate of the bug: http://yafaray.org/node/289

As discussed in http://yafaray.org/node/289#comment-1162 , I've sent a proposed change to YafaRay developers for review.

Please john, will you provide an example XML file similar to the image you used in your bug report? I would like to test it with my new changes to see if it also improves.

#4

Hi David,

You send the XML file required!

Greetings

John

AttachmentSize
VolumetricError.jpg 38.53 KB
XMLVolumeError.zip 488.3 KB

#7

Hello, John.

Thanks to your XML scene, I could find something else in my changes that needed to be adjusted. Now, I can get the render correct (see attached picture).

This was indeed a difficult problem related to the way Volumetrics was originally designed. I had to make significant structural changes to the way Volumes are rendered to be able to include them in the raytracing process. I hope it works better now and it does not cause new issues.

I will start preparing a build of the new Experimental release and will let you know when it's ready for you to test it.

AttachmentSize
VolumetricError-Fixed.png 384.24 KB

#8

Status:ready to commit» fixed

Fixed in YafaRay-E (Experimental) v1.0.0

 

For more information, see:  http://www.yafaray.org/community/forum/viewtopic.php?f=12&t=5117

 

If you still have this issue with the new version please let us know.

#9

Hi David,

Thanks for your work these days try the beta and if there are problems we will notify you !!!

see you soon

John

#10

Status:fixed» closed

Automatically closed -- issue fixed for 2 weeks with no activity.